Autofocus behavior

A place for users to ask questions and search for already asked questions. "BE NICE" and helpful!
Post Reply
Marian Scheja
Posts: 9
Joined: Sat Oct 02, 2021 8:08 pm
Location: Nordrhein-Westfahlen, Cologne
Country: Germany
Nickname: Marian
Laser Machine Make or Type: BRM-Laser
Laser Power: 100W
Laser Bed Size: 125x90mm
Home Position: TR
Control Software: RDWORKS
RDWorks Version: v8.01.54
Ruida Controller: RDC6445
Accessories: BRM-Laser with RDC6445GT5(EC), Rotary, ...
Windows Version: 10 64bit

Autofocus behavior

Post by Marian Scheja »

Hi everyone,

i have a question about my autofocus behavior (RDC6445GT5).
I have a Z bed with limit switch (NO) on top position which is wired to Z- limit input.
I installed the red pen type autofocus sensor (there is is a NPN NO inductive sensor inside).
As recommended i wired it in parallel to the Z- Limit.

Reset is enabled for X, Y and Z. This works as intended.
Z-Axis travel is limited to 250mm (Breadth)

After reset (homing) the Z table is on top position and i can move it down by 250mm before the controller limits further movement. -> Good
If i use autofocus on an object (i.e. 100mm), it touches the pen-sensor twice, lowers the table by the set focal distance (i.e. 10mm) and sets the Z coordinate to zero.
But after that operation the controller allows travel down by 250mm which would crash my machine. -> Dangerous
The travel should be limited to the remaining 140mm of travel (250mm -100mm -10mm = 140mm).

In user settings -> focus -> "focus sensor": ich can choose between "z limit" and "Probe".
Currently "z limit" is selected.

If i select "probe", the behavior is even more strange: Table moves up, touches probe or z-limit, moves down till i cancel the operation (i don't want to crash the bed). Even if i touch the probe by hand while the bed is moving down nothing happens.
Wiring the probe to "z+", it is not recognized by the controller. I even tried the "in1" which apparently has no function at all.

Is this a fault in my controller/firmware, or do you experience the same behavior with other controllers (6445g/s, 6442, others)
(for testing you should temporary limit the travel (breath) to a smaller value to prevent crashing your machine)

Btw. i have made pictures of the disassembled pen-probe. Maybe it is useful to someone.
probe.jpg
You do not have the required permissions to view the files attached to this post.
Post Reply

Return to “User Questions and Help”